# Table of Contents

1. Introduction .................................................................................................................. 4
2. Terminology .................................................................................................................. 5
4. Markers ......................................................................................................................... 8
   4.1 Symbol Markers ....................................................................................................... 8
   4.2 Shape Markers (part 1) .......................................................................................... 10
   4.3 Marker Styles ......................................................................................................... 10
   4.4 Shape Markers (part 2) .......................................................................................... 12
   4.5 Symbol + Shape Markers ....................................................................................... 14
   4.6 Photo Markers ........................................................................................................ 15
   4.7 Text Markers .......................................................................................................... 18
   4.8 Font styles .............................................................................................................. 19
5. Hotspot Actions and Marker Settings ........................................................................... 19
   5.1 Controlling when to show a hotspot’s content ....................................................... 20
   5.2 Linking to another Web Page .................................................................................. 20
   5.3 Linking to another Map or Data Sheet .................................................................... 20
   5.4 Executing JavaScript ............................................................................................... 20
   5.5 Marker Settings ...................................................................................................... 21
   5.6 Marker Zoom Settings ............................................................................................ 21
   5.7 Setting Map and Marker Zoom Limits for SVG Maps ............................................. 25
6. Importing Marker Shapes .............................................................................................. 27
   6.1 How it works ............................................................................................................ 27
   6.2 Understanding Area tag attributes ......................................................................... 28
   6.3 Import Marker Shape Options ................................................................................ 29
   6.4 Updating marker shapes ......................................................................................... 30
   6.5 Combining multiple areas into one marker ............................................................. 30
   6.6 Import Marker Shapes from HTML File ................................................................... 30
Appendix A – MapEdit ....................................................................................................... 31
1 Introduction

What is this guide about?
This guide explains what hotpots and markers are, how to use them, and how to create them. It contains both basic and advanced subject matter.

Who this guide is for
This guide is recommended reading for anyone using MapsAlive, but will be especially helpful for people who want to produce interactive maps that have a custom appearance and/or behavior.

How to get more information or assistance
If you need more details, a better explanation, or just a little bit of hand-holding, we are here to help. Please email questions to support@mapsalive.com.

You can find other MapsAlive User Guides at http://www.mapsalive.com/LearningCenter.
2 Terminology

MapsAlive
MapsAlive is a web application that runs in your PC or Mac browser with a high-speed internet connection. There is no software to install and you are always using the latest version.

Tour Builder
The MapsAlive Tour Builder is where you create, edit, and publish interactive maps. When you login to your MapsAlive account you can use the Tour Builder to upload map images and photos, enter text, create hotspots, choose layouts, and set the appearance and behavior of your interactive maps.

Tour
A tour is one or more interactive maps and data sheets that are usually related to each other. Many tours might only have one map. Other tours, like a house tour, might have several floor plans together in one tour to let a prospective buyer explore the house. You publish your tours when you are ready for other people to use them.

Map
A map is a component of your tour that serves as a container for a single map image, the map’s hotspots and hotspot content. You upload a map image and add hotspots to the map using the Tour Builder.

Data sheet
A data sheet contains photos, text and other information related to your tour, but it has no map. A data sheet might be used to display introductory text, contact information, specifications, or similar non-interactive content.

Map Image
A map image can be any image such as a diagram, floor plan, geographic map, or even a photograph. You can think of it as a background layer beneath a layer of hotspots. You upload one map image for each map in your tour.

Hotspot
A hotspot is a location on an interactive map that shows content associated with that location when the mouse moves over it, off of it, or clicks it. The size, shape, and appearance of a hotspot are indicated by a marker.

Hotspot Content
Hotspot content is the information associated with a specific hotspot such as photos, text, and videos. When the mouse moves onto or clicks a hotspot, the content displays. A hotspot can also have an action associated with it.

Marker
A marker can be an image (like an arrow), a visible shape (like a rectangle or polygon), or an invisible shape, that marks the presence of a hotspot on a map. Each hotspot on a map has a marker associated with it. The marker can be unique to one hotspot or the marker can be used by several hotspots.

Tiled versus Popup Content
Tiled content means that your hotspot content displays alongside the map – both the content and the map display within the rectangular canvas area. Popup content is hotspot content that displays in a rectangular area that pops up on top of your map when you mouse over a hotspot on the map.

Canvas
Every tour has a canvas area that displays one map or data sheet. For maps with tiled content, the canvas area contains the map image and the hotspot content. For maps with popup content, the canvas area contains only the map image. For data sheets, the canvas area contains the photo and text for the data sheet.
Symbol
Symbols are images, typically small in size, that are used to create markers that display on a map. MapsAlive comes with many symbols that you can use to make your own markers or you can upload your own symbols to create custom markers. Symbols are image files such as jpeg, gif or png files.

Shape
Shapes are circles, rectangles and polygons that have a size, a border thickness, color and opacity, and a fill color and opacity. Circle and rectangle shapes can easily be defined in MapsAlive. To create polygon shapes such as state or country outlines, you can import shape coordinates and let MapsAlive automatically create hotspots and markers for you – see section 5.7 for more details.

Normal Appearance
Every marker has a normal appearance and a selected appearance. The normal appearance is what the marker looks like when the mouse is not over the marker. If a marker has a different normal appearance and selected appearance, it creates an animated feel because the appearance changes as you mouse onto and off of the hotspot.

Selected Appearance
The selected appearance of a marker is what the marker looks like when the mouse moves over the marker. If a marker has a different normal appearance and selected appearance, it creates an animated feel because the appearance changes as you mouse onto and off of the hotspot.
3  Hotspot vs. Marker – What’s the Difference?

Think of a hotspot as an important location on a map. When you move your mouse over that location, you want something to happen, for example, have a photo appear. On a floor plan, a hotspot might be where you were standing when you took a picture of the kitchen. On a map of the world, a hotspot might be the location of an entire country. You add a hotspot to a map by choosing New > Hotspot in the menu.

A hotspot by itself has no size or appearance and therefore every hotspot has a marker associated with it. You choose a hotspot’s marker from the Marker dropdown on the Edit Hotspot Content screen.

A marker is a symbol or a shape that has size and appearance. The marker determines how big the hotspot is and what it looks like. On a floor plan, the marker might be an arrow pointing to the kitchen at the place you were standing when you took a picture. On a map of the world, a marker might be the shape of an entire country.

Every hotspot has one marker, but a marker can be used by many hotspots. For example, the same arrow marker can be used in many locations on a floor plan to show all the places from which photos were taken. Some markers are bound to just one hotspot because they are not useful to any other. For example, a marker for the shape of Greece cannot be used to show the shape of Bulgaria.

You can see all the markers in your MapsAlive account by going to the Marker Library screen. You get there by choosing Library > Markers in the menu. If you only want to see the markers used by the tour you are currently working on, choose Library > Markers > Filter Markers in the menu. Note that bound markers only appear on the Marker Library screen when you choose to filter markers.

Another thing about hotspots is that they have data and behavior associated with them. A hotspot’s data is usually a photo, text, or video. By default, a hotspot’s behavior is to display its data when the mouse move over the hotspot’s marker, but you can have other behaviors, for example, to display a web page or open a PDF document when the hotspot’s marker is clicked.

Markers don’t have data or behavior, but they have two appearances – normal and selected. The normal appearance is what the marker looks like when the mouse is not over it. The selected appearance is what the marker looks like when the mouse is over it. For example, an arrow marker on a floor plan might normally be blue, but turn red when you mouse over it. Blue is the normal appearance and red is the selected appearance. Note that a marker’s normal or selected appearance can be invisible in which case the marker is only used to designate the hotspot’s size and shape.

Now you know the difference between hotspots and markers, but there is a lot more to learn about both, especially if you want to create your own custom markers. If the markers that come with MapsAlive suit your needs, you can stop reading now if you like.
4 Markers
MapsAlive lets you choose from the five kinds of markers listed below. Each will be discussed in detail in the sections that follow.

- Symbol Markers
- Shape Markers
- Symbol + Shape Markers
- Photo Markers
- Text Markers

4.1 Symbol Markers
A symbol marker is the simplest type of marker. It is just an image, usually an icon like an arrow, dot, or star, but you can use any image in a symbol marker. Here are a few examples of symbol markers.

A symbol marker has two images associated with it as shown in the figure below. One image is for the marker's normal appearance and the other is for its selected appearance.

A symbol marker will have an animated effect if the selected symbol is slightly different than normal symbol. Using the two images below, the book will appear to open when you mouse over it.

You can use the symbol markers that come with MapsAlive or you can create your own.

Creating your own symbol marker
Three steps are required to create a symbol marker.

1. Add the marker’s normal image to your MapsAlive account by choosing New > Resource > Symbol from the menu. Give the symbol a meaningful name such as BookClosed, then browse for the image on your computer and load it.

2. Add the marker’s selected image to your MapsAlive account by choosing New > Resource > Symbol from the menu. Give the symbol a meaningful name such as BookOpen, then browse for the image on your computer and load it.
3. Add a new symbol marker to your account by choosing New > Resource > Marker from the menu. Give the new marker a meaningful name such as Book and set the Marker Type dropdown to Symbol. Then choose the normal symbol you just uploaded from the Normal Symbol dropdown. Also choose the selected symbol you just uploaded from the Selected Symbol dropdown.

Using your new symbol marker
After you complete the three steps above, you can click the Save button and then preview your new symbol marker by moving your mouse over and off of it in the Marker Preview area in the upper right part of the Edit Marker screen.

Your new marker is now ready to use for a hotspot. It will appear in the Marker dropdown the next time you go to the Edit Hotspot Content screen (if it’s not in the list, you probably have the Filter Markers option checked – turn it off by choosing Library > Filter Markers in the menu).

Symbol Marker Tips and Techniques
- If you want to use symbol images that contain transparent areas, you need to upload gif or png image files. Jpg images do not support transparency. Only one color in a gif image can be transparent. For best results, use png images for your symbols.
- Symbol images are typically small, for example, 24 x 24 pixels, but you can use larger images if you like. Whatever size you upload is the size the symbol marker will be when placed on a map.
- You don’t have to use different normal and selected symbol images. If you do not want a symbol marker to change appearance when moused over, choose “No Symbol” from the Selected Symbol dropdown on the Edit Marker screen.
- If you don’t want to clutter your map with symbols, but you want a symbol to appear when the mouse moves over a hotspot, choose “No Symbol” from the Normal Symbol dropdown on the Edit Marker screen.
- To see all the symbols in your account, go to the Symbol Library screen by choosing Library > Symbols in the menu. On that screen, the number that appears after a symbol tells you how many different markers use that symbol. Click the number to see a list of those markers.
- You can replace a symbol image any time by uploading a new image on the Edit Symbol screen. When you replace a symbol image, all markers that use that symbol will be updated automatically.
4.2 Shape Markers (part 1)

A shape marker is a circle, rectangle, polygon, line, or hybrid that defines the size, shape, color, and transparency of a hotspot. A hybrid shape contains two or more of the other kinds of shapes to form a single, multi-part shape. Here are examples of the five kinds of shape markers.

Each kind of shape marker has information associated with it that defines the shape itself. A circle shape has a radius. A rectangle shape has a width and height. A polygon shape has a set of coordinates that define its outline. A line shape has a set of coordinates that define its path. A hybrid contains information about each of its parts. In the image above, the shape on the far right is a hybrid with four polygon shapes that make up the island of Maui, Hawaii. On a map with this marker, when you mouse over any one of the Maui polygons, it and the other three polygons will change to the marker’s selected appearance.

Unlike a symbol marker, a shape marker has no images associated with it. Instead it has a marker style as shown in the figure below.

Before continuing our discussion of shape markers, let’s first explain marker styles.

4.3 Marker Styles

A marker style defines the appearance of the shape portion of a marker. Every marker except for symbol markers has a shape associated with it. A shape’s appearance has five elements for its normal appearance and five for its selected appearance. These elements are listed below.

- Fill Color
- Fill Color Opacity
- Line Color
- Line Color Opacity
- Effects

There is a sixth element that is shared by both the normal and selected appearances:
• **Line Thickness**

Think of a marker style like a style in a Microsoft Word document. In Word, a style can be applied to a paragraph to set the font, text color, and many other attributes. You can apply the style to many paragraphs, and if you change the style, the appearance of all the paragraphs that have that style change automatically. Without styles you would have to set text attributes on every paragraph that needed them, and then set them all again when you wanted to make a change.

In MapsAlive, you use marker styles pretty much the same way. For example, suppose you have a map of the United States with 50 shape markers, one for each state. When you first imported the shapes, you chose a default marker style that made all the states blue. If you want to make all the states red, you can just edit that single marker style to change the fill color from blue to red and all the states turn red. Or, maybe you want to leave the democratic states blue and make the republican states red. To do that, you can select just the republican states and give them a red marker style.

You can use the marker styles that come with MapsAlive, or you can create your own.

**Creating your own marker style**

Creating a new marker style is easy. First choose **New > Resource > Marker Style** in the menu. That will take you to the **Edit Marker Style** screen where you can give the new style a meaningful name like Democrat. There you can also set the colors, opacity, and effects for both the normal and selected appearances. Marker style effects are described in the next section.

Your new marker style is now ready to use. It will appear in the **Marker Style** dropdown the next time you go to the **Edit Marker** screen.

**Marker style effects**

There are three marker style effects that you can use to add interest to your markers:

- **Glow**
- **Shadow**
- **Blend**

The glow effect adds a glow around a shape. The color of the glow is the marker style’s line color even if the style’s line thickness is set to zero. In section 4.2 above, the Maui marker has a light blue fill color and a green glow.

The shadow effect adds a drop shadow to a shape. In section 4.2 above, the circle marker has a mauve fill color and a gray shadow.

The blend effect will be familiar to people who work with programs like Adobe Photoshop that let you layer one image on top of another. In MapsAlive, a shape marker is placed on a layer over your map image. The settings you choose for the marker style determine how the underlying map image will be affected by the overlay. In the image below, all three circles have the same fill color, but each alters the
appearance of the map in a different way. The first circle has 100% fill color opacity without blend – it is completely opaque and the underlying map image does not show through at all. The second circle has 70% opacity without blend. The third circle has 70% opacity with blend. The fourth circle has 100% opacity with blend.

As you can see, the blend effect applied to the third and fourth circles maintains the shape’s color and opacity while keeping the dark areas of the map image dark. Without blend, the dark areas of the map tend to get washed out.

In many cases, just typing the word glow, blend, or shadow in either the Normal Effects or Selected Effects fields on the Edit Marker Style screen will work pretty well. But to fully utilize effects, you’ll need to read about them in the Marker Shapes Effects section of the MapsAlive User Guide for JavaScript API.

Marker Style Tips and Techniques

- To replace the marker style for several markers on the same map, choose Map > Replace > Marker Styles in the menu. Check the box for each marker whose style you want to replace and choose a different style from the New Marker Style dropdown. Click the Replace button and those markers get the new style.

- You can duplicate a marker style that’s close to what you want and make changes to the copy without affecting the original. First choose Library > Marker Styles and then click the style you want to duplicate. On the Edit Marker Style screen, choose Library > Duplicate in the menu.

- To see all the marker styles in your account, go to the Marker Style Library screen by choosing Library > Marker Styles in the menu. On that screen, the number that appears after a style tells you how many different markers use that style. Click the number to see a list of those markers.

- When you just type the word “blend” for a marker style’s effect, the blend mode defaults to multiply. There are eight other blend effects. They are described in the MapsAlive User Guide for JavaScript API.

4.4 Shape Markers (part 2)

Now that you know about marker styles, we can continue our discussion of shape markers. Shape markers let you highlight areas on your map such as a room on a floor plan or a region on a geographic map. Using marker styles, you can create shape markers that have a solid color or are semi-transparent letting you see through the shape to the map image below. You can even create invisible shape
markers. A common technique is to make a shape’s normal appearance invisible and its selected appearance visible so that the shape “lights up” when you move your mouse over it.

By using marker style effects, you can make shapes glow or have drop shadows to make them really stand out on the map. A common technique is to have a glow effect only appear when you mouse over the shape.

Creating circle and rectangle shape markers
You can easily create circle and rectangle shape markers in the Tour Builder by following these steps:

1. Add a new shape marker to your account by choosing New > Resource > Marker in the menu. Give the new marker a meaningful name and set the Marker Type dropdown to Shape.

2. Choose either Circle or Rectangle from the Shape dropdown.
   a. If you choose Circle, enter a value for Circle Radius.
   b. If you chose Rectangle, enter values for the Rectangle Size width and height.

Creating polygon, line, and hybrid shape markers
Polygon, line, and hybrid shapes are defined by a list of coordinates that specify how the shape is drawn. Think of the coordinates as the dots in a dot-to-dot kid’s drawing. Each dot is a point described by two numbers (x and y) that indicate how far the dot is from the top left corner of the map. Since typing a long list of numbers by hand is not very practical, you must import the coordinates into MapsAlive from a file.

The coordinates that MapsAlive requires are the very same ones that browsers use to render what’s known as an HTML image map (do a Google search for “HTML image map” to learn more). This format has been supported by browsers since the beginning of the web. As such, there are lots of programs that will create shape coordinates for you and let you save them to a file. There are very powerful programs like Adobe Illustrator and simple, inexpensive utilities like MapEdit (only $15). Other tools that will do the job are CorelDRAW, Dreamweaver, Fireworks, Image Ready, and Paint Shop Pro to name a few. See the appendices of this document to learn how to use some of these programs.

To learn about importing coordinates for polygons, lines, and hybrid shapes, skip ahead to section 5.7 of this document.

Using your new shape marker
After you have created or imported shape markers, they will appear in the Marker dropdown the next time you go to the Edit Hotspot Content screen (if they are not in the list, you probably have the Filter Markers option checked – turn it off by choosing Library > Filter Markers in the menu).
4.5 Symbol + Shape Markers

A symbol + shape marker is a combination of a symbol marker and a shape marker. It has a normal symbol, a selected symbol, and a marker style as shown below.

These kinds of markers are useful when you want to use a shape to highlight an area on your map, but also pinpoint a specific location with a symbol image. Below are examples of symbol + shape markers:

Creating your own symbol + shape marker

Five steps are required to create a symbol + shape marker.

1. Add the marker’s normal symbol image to your MapsAlive account by choosing New > Resource > Symbol from the menu.

2. Add the marker’s selected symbol image to your MapsAlive account by choosing New > Resource > Symbol from the menu.

3. Add a new symbol + shape marker to your account by choosing New > Resource > Marker from the menu. Set the Marker Type dropdown to Symbol + Shape.

4. Choose the normal symbol you just uploaded from the Normal Symbol dropdown. Also choose the selected symbol you just uploaded from the Selected Symbol dropdown.

5. Choose a Shape type from the dropdown.
   a. If you choose Circle, enter a value for Circle Radius.
   b. If you chose Rectangle, enter values for the Rectangle Size width and height.

Note that you cannot create a new symbol + shape marker that uses a polygon, line, or hybrid shape; however, you can convert an existing polygon, line, or hybrid shape marker into a symbol + shape marker. To do that, click the existing shape on the Marker Library screen and then on the Edit Marker screen, change that shape’s Marker Type from Shape to Symbol + Shape.

Be default, the symbol will be centered within the shape, but you can place it anywhere you like by changing the Symbol Location dropdown on the Edit Marker screen from Centered in shape to Positioned at X,Y. Then enter values for X and Y.
Using your new symbol + shape marker
After you complete the steps above, you can click the Save button and then preview your new symbol + shape marker by moving your mouse over and off of it in the Marker Preview area in the upper right part of the Edit Marker screen.

Your new marker is now ready to use for a hotspot. It will appear in the Marker dropdown the next time you go to the Edit Hotspot Content screen (if it’s not in the list, you probably have the Filter Markers option checked – turn it off by choosing Library > Filter Markers in the menu).

4.6 Photo Markers
Like all markers, a photo marker is associated with a hotspot. What makes a photo marker special is that it displays a thumbnail image of whatever photo belongs to the hotspot. When you mouse over the marker, the hotspot’s larger photo appears as shown at right.

A photo marker’s image changes automatically when you change the hotspot’s photo.

As with all markers, you can use the same photo marker for many hotspots. For example, suppose you created a photo marker named Employee and your map is an org chart with a hotspot for each person in your company. When there is a personnel change, you can upload a new photo for the affected hotspot, and that hotspot’s photo marker will update automatically with a new thumbnail. Even though every employee hotspot is using the same photo marker, each instance of the photo marker on the map will display a unique thumbnail.

A photo marker’s thumbnail is positioned inside a rectangle shape. You control the appearance of that shape with a marker style, just like you do with a shape marker. A photo marker can also have caption text which is styled by a font style. Thus a photo marker has a marker style and a font style associated with it as shown below.

![Diagram of marker style and font style associations]

Because a photo marker has a marker style, you can add effects like glow and shadow to the shape. Additionally, you can apply special effects to the thumbnail image. For example, you can make the normal appearance of a color photo appear in black and white and then change to color when you mouse over it.
Photo markers that come with MapsAlive
MapsAlive comes with the several ready to use photo markers. They are listed below and shown at right.

- Classic (1st row)
- Classic Black & White (2nd row)
- Classic Crop Square 2x, 3x, and 4x (3rd row)
- Classic Crop Square Left, Right, Top, Bottom (4th row)
- Sepia, Modern Black & White, and Modern (5th row)
- Neon, Classic with Caption, and Gold Frame (6th row)

Creating photo markers
Creating your own photo markers is easy and fun. Follow the instructions here to create a new photo marker from scratch, or read the next section to learn how to duplicate an existing marker so that you can customize it.

You create a photo marker in the Tour Builder by following these steps:

1. Add a new photo marker to your account by choosing New > Resource > Marker in the menu. Give the new marker a meaningful name like Employee and set the Marker Type dropdown to Photo.

2. Choose a marker style from the Marker Style dropdown list. Any style that you would use for a shape marker can also be used for a photo marker.

3. Choose other options on the Edit Marker screen to control the appearance of the photo marker. The options let you add a caption, specify the size and shape of the marker’s rectangle specify if and how the photo will be cropped for the thumbnail image, add a matte around the thumbnail, and add special effects to the thumbnail.

Note that if you add a caption to the photo marker, you can specify the same caption text for every instance of that photo marker on your map or you can have the caption text be taken from the hotspot’s title automatically. For example, in the employee example, if you use the employee’s position (president, manager, etc) for the hotspot title, then each instance of the photo marker will show the employee’s photo and thumbnail automatically. If you change the hotspot title text e.g. from Manager to Supervisor, the text will update in the photo marker automatically.

Duplicating photo markers
An easy way to get the photo marker you want is to pick one that’s close, duplicate it, and then customize it the way you like. Choose the marker you want to start with on the Marker Library screen and then choose Library > Duplicate in the menu. Now edit the duplicate to be just what you want.
**Using your photo marker**

After you complete the steps above to create a photo marker, you can click the Save button and then preview the effects of the options you choose for your new photo marker by moving your mouse over and off of it in the Marker Preview area in the upper right part of the Edit Marker screen. Because the actual photo that will appear on your map comes from the marker’s hotspot, the preview uses a generic photo. To see the actual effect of your choices, you’ll need assign the marker to a hotspot and then go to Tour Preview.

Your new marker is now ready to use for a hotspot. It will appear in the Marker dropdown the next time you go to the Edit Hotspot Content screen (if it’s not in the list, you probably have the Filter Markers option checked – turn it off by choosing Library > Filter Markers in the menu).
4.7 Text Markers
Like all markers, a text marker is associated with a hotspot. What makes a text marker special is that it displays the title text of whatever hotspot that uses it. The width and height of the marker can be fixed or made to automatically adjust to fit the text. In the image below, three instances of the same text marker are shown for three hotspots. The first two markers are showing their normal appearance and the third marker is showing its selected appearance.

A text marker's text changes automatically when you change the hotspot's title. Text markers are very handy for creating labels, clickable menu items, or buttons right on your map.

A text marker's text is positioned inside a rectangle shape, or inside a circle shape as shown at right. You control the appearance of that shape with a marker style, just like you do with a shape marker. The text itself is styled by a font style. Thus a text marker has a marker style and a font style associated with it as shown below.

Creating text markers
You create a text marker in the Tour Builder by following these steps:

1. Add a new text marker to your account by choosing New > Resource > Marker in the menu. Give the new marker a meaningful name and set the Marker Type dropdown to Text.
2. Choose either Rectangle or Circle from the Shape dropdown.
3. Choose a marker style from the Marker Style dropdown list. Any style that you would use for a shape marker can also be used for a text marker.
4. Choose a font style from the Font dropdown list.
5. Choose other options on the Edit Marker screen to control the appearance of the text marker. The options let you add a set the normal and selected text colors, alignment, padding, and whether or not the marker automatically sizes itself to fit the text.

Note that you can specify the same text for every instance of the text marker on your map or you can have the text be taken from the hotspot's title. For example, you might need several instances of a text marker that say “Sold” to mark sold lots on a plot plan. Just type “Sold” in the Text field on the Edit Marker screen. If you want the text to come from the hotspot title, leave the Text field blank.
Using your text marker
After you complete the steps above to create a text marker, you can click the Save button and then preview the effects of the options you chose for your new text marker by moving your mouse over and off of it in the Marker Preview area in the upper right part of the Edit Marker screen. If the actual text is coming from the marker's hotspot title, the preview text says “Sample.”. To see the actual effect of your choices, you'll need assign the marker to a hotspot and then go to Tour Preview.

Your new marker is now ready to use for a hotspot. It will appear in the Marker dropdown the next time you go to the Edit Hotspot Content screen (if it's not in the list, you probably have the Filter Markers option checked – turn it off by choosing Library > Filter Markers in the menu).

4.8 Font styles
You can define your own font styles and use them when creating text or photo markers. You can also use a font style for tooltips. When you define a font style you can choose a font family, font size, font weight and whether the text is bold, italic, or underlined.

Once you define a font style you can use it with any text marker, photo marker, or tooltip. When you make changes to a font style, any markers or tooltips that use it are updated automatically.

You can use font styles to dress up an interactive map or to make a map more consistent with the text used in a web page that embeds it. And if you don't want to create your own, MapsAlive comes with a number of font styles that are ready to use.

Creating font styles
You create a font style in the Tour Builder by following these steps:

1. Add a new font style to your account by choosing New > Resource > Font Style in the menu. Give the new font style a meaningful name.
2. Choose the font's family, size, and weight.

The preview on the Edit Font Style screen updates automatically as you change font style options. Note, however, that the preview is being rendered by the browser as HTML. It gets converted to a graphic when used in a text or photo marker and therefore may look a little different when the marker is placed on your map. For an accurate preview, assign the font style to a marker and assign the marker to a hotspot. The go to Tour Preview.

5 Hotspot Actions and Marker Settings
You can choose to display a hotspot's content when the user mouses over a marker or clicks a marker, or you can choose to not show the content at all. Hotspot actions let you control what happens when a user clicks, mouses over, or mouses off a marker. Hotspot actions are used to link to other web pages, link to another map or data sheet in your tour, or execute JavaScript. To control the hotspot actions and marker setting choose Hotspot > Hotspot Actions in the menu.
5.1 Controlling when to show a hotspot’s content

Usually you want to display your hotspot content when the user mouses over the hotspots on your map. For some maps, however, it might make more sense to display your hotspot content when the user clicks the hotspots. This is useful for maps with a lot of hotspots that are close together or for maps where the user expects to click to see the content, such as a numbered diagram.

In other cases you might not want to display content for a hotspot. Some maps have hotspots that only display a tooltip, but no other content. Other maps may have hotspots that are clickable only to navigate to other maps or web pages. In these cases, you can choose not to display a hotspot’s content at all.

You can choose different options for different hotspots on your map – they don’t all have to be set the same way. For example, you might have a hotspot with a text marker that instructs users to click to view a related web page, but the other hotspots show images and text when the user mouses over them.

5.2 Linking to another Web Page

You can link to another web page when a user clicks a hotspot’s marker. You can specify any URL to link to. You can choose which hotspots link to another web page – not all hotspots on your map have to be clickable.

Another way to link to another web page is to add a link in the text area of your hotspot content. This is useful if you have several links related to one hotspot. Since only one action can occur when a user clicks a hotspot, you might add your links to your text if you want to allow the user to click a hotspot to go to another map or data sheet in your tour (see section 5.3) or execute JavaScript (see section 5.4).

5.3 Linking to another Map or Data Sheet

You can also link to another map or data sheet in your tour when a user clicks a marker. This is common when you have a tour with multiple maps or data sheets. For example, you can add a hotspot to a first floor plan that lets you click to go to the second floor plan in the same tour, and another marker on the second floor plan to go back to the first floor plan. When using this option, you may want to choose not to show any hotspot content if you are just using the marker to navigate.

5.4 Executing JavaScript

You can execute JavaScript when a user clicks, mouses over or mouses off a marker. For example, you might want to play a sound when a user clicks a marker. Or, you could change another marker’s appearance when a user mouses over a marker. These are two examples of JavaScript functions in the MapsAlive JavaScript API, but you can write your own functions and call them.

When you set the Click Action, Mouseover Action, or Mouseout Action on the Hotspot Actions screen to JavaScript, you can also type in your JavaScript code.
5.5 Marker Settings
There are three settings that let you set a marker's initial appearance or behavior. These settings are most useful when you want to control the appearance and behavior of markers dynamically using the MapsAlive JavaScript API. To control the marker settings choose Hotspot > Advanced Hotspot Options in the menu.

**Marker is Hidden**
This setting makes the marker invisible on the map and the marker will not respond to mouseover, mouseout, or click events. You might set a marker invisible in the Tour Builder and then set its appearance dynamically by making a JavaScript call from a web page containing your tour.

**Marker is Disabled**
This setting lets you disable mouseover, mouseout, and click events, though the marker is still visible in its normal appearance on the map. A marker that is disabled does not change appearance when you mouse over it. Again, you can enable a marker dynamically by making a JavaScript call from a web page containing your tour.

> Hotspots whose marker is disabled can still be selected from the directory and the hotspot content displays when the entry is clicked. This avoids the behavior of clicking an entry in the directory and having nothing happen. If you don’t want the user to be able to select a hotspot with a disabled marker from the directory you can set the Exclude From Directory option on the Edit Hotspot Content screen.

**Marker is Static**
A static marker does not change appearance when the mouse moves over it, but it does still respond to mouseover, mouseout and click events.

5.6 Marker Zoom Settings
There are three additional marker settings that control how the marker behaves when you zoom in and out. These settings only apply when MapZoom is enabled.

**Markers Zoom**
This setting controls whether markers scale up and down as you zoom the map in and out. When markers are set to zoom they get larger as the map zooms in and they get smaller as the map zooms out. In other words the markers and the map scale together. In the example below you can see that the pin marker and the blue text marker are smaller in the screen shot on the left. The screen shot on the right shows that the markers are scaled with the map as you zoom in and appear larger.
Use this setting when you want the marker size to scale in proportion to the map image as you zoom. You can also use this setting when you are using rectangle or circle shape markers that match an area on the underlying map image such as a room on a floor plan or a numbered circle on a diagram. In this case, you would want the marker to scale with the map so they always fit the area.

This setting has no effect on imported marker shapes or if you choose a Ready Map and use its associated shapes. Those kinds of markers are automatically “bound” to the map and always scale when you zoom the map in and out.

To control whether all the markers on a map scale as you zoom choose **Map > Advanced Map Options** and check or uncheck the Markers Zoom checkbox. To control whether an individual markers scales as you zoom go to **Hotspot > Advanced Hotspot Options** and choose from the Marker Zooms dropdown.

Note that you can control the default setting of the Markers Zoom option on the **Account > Preferences** screen. The setting you choose here will be used whenever you create a new map, but you can still override it on a per map or per hotspot basis.

**Zoom Visibility Threshold**

This setting lets you make a marker visible or invisible based on how far the map is zoomed in or out. This feature can be used to keep your map from getting too cluttered with markers when your map is zoomed all the way out.

The map on the left has green square markers and text markers for cities on the island of Oahu. Because the map is zoomed out, the text labels are too small to read and make the map more cluttered than it needs to be at this zoom level.

You can use the Zoom Visibility Threshold to improve this map by setting the text markers to only become visible once the map is zoomed in to a certain level.

In the example below the Zoom Visibility Threshold is set to 70%
for the text markers which means they do not become visible until the map is zoomed in to 70% or more. The map on the left shows what the map would look like when it is zoomed all the way out and the map on the right shows what it looks like when it is zoomed all the way in.

You can use the Zoom Visibility Threshold setting to make markers become visible as you zoom the map in or as you zoom the map out. You set the option on a per hotspot basis by going to Hotspot > Advanced Hotspot Options in the menu. Use a positive percentage to specify that a marker should become visible when the map is zoomed in by that amount. Use a negative percentage to specify that a marker should become visible when the map is zoomed out by that amount.

**Understanding the Zoom Range**

A map is zoomed to 100% when you zoom all the way in. When you zoom all the way out the zoom percentage is based on the original map size and the map area in your tour. When the map is zoomed all the way out you see the whole map, but it is scaled to fit within the map area rectangle.

In the example below, the map on the left is zoomed all the way out so it fits within the map area. It has been scaled to 50% of the original map image size. The map on the right is zoomed all the way in so only part of the map displays within the map area – the map is zoomed in to 100%. (The outer area of the map image on the right is shown dim to better illustrate the part of the map that you see within the map area – it is not visible in the tour).
In this example, the zoom range is 50% to 100%. If you set the Zoom Visibility Threshold to a value within this range, markers will become visible or invisible as you zoom.

**Is Not Anchored to Map**

This setting lets you create a marker that always appears in a fixed location on your map regardless of how you pan or zoom the map. A marker that is not anchored to the map always appears in the same relative location as you pan and zoom. For example, if you place a marker in the upper right corner of the map and check the Is Not Anchored to Map option, the marker will always be visible in the same location on the map even if you pan or zoom because it is not anchored to a specific location on the map. In the example below the red text marker in the upper right corner is not anchored to the map. The map on the left is zoomed all the way out. The map on the right is zoomed all the way in and panned a little toward the top, but the text marker remains in the same place so it is always visible. This option is useful for text or photo markers when you want the user to always see some information or perhaps be able to click a marker regardless of how the map is zoomed.

You set this option for a hotspot by going to **Hotspot > Advanced Hotspot Options** in the menu and checking or unchecking the Is Not Anchored To Map checkbox.
5.7 Setting Map and Marker Zoom Limits for SVG Maps

When you use an SVG (scalable vector graphic) map there are two options that let you control how much you want the map itself to zoom and how the markers should scale in relation to the map.

These options only apply when MapZoom is enabled and you are using an SVG map.

**Map Zoom Limit**

Because an SVG map is scalable it does not have fixed dimensions like a bitmap image does. This means you can zoom in as much as you want without affecting the quality of the image. MapsAlive lets you set a Map Zoom Limit to specify how far you want to be able to zoom in. The setting you choose will depend on how detailed your map is, the size of your map area, and what you want the user to see when they zoom in all the way. You can choose a Map Zoom Limit between 2 and 10. A value of 2 means the map can be zoomed to twice the size of the map area rectangle within your tour, a value of 3 means the map can be zoomed to three times the size of the map area rectangle within your tour, and so on.

**Marker Zoom Limit**

The Marker Zoom Limit is a unique feature of MapsAlive that lets you control how markers are sized when the map zooms in or out. Normally, when your map is zoomed all the way out, the markers are also zoomed and so they appear smaller. The markers scale with the map as you zoom in so they get bigger and more visible. You can control how much the markers scale as you zoom by changing the Marker Zoom Limit.

The Marker Zoom Limit setting is tied directly to the Map Zoom Limit. When both limits are set to the same value, like 5, the map and markers scale together. If you set the Marker Zoom Limit to a value less than the Map Zoom Limit, the markers will stop scaling and display at 100% when the map is zoomed to the Marker Zoom Limit level. The examples below illustrate how this works.

In the first example, the Map Zoom Limit and the Marker Zoom Limit are both set to 5.

This means that the map can be zoomed to five times the size of the map area rectangle and the markers will scale in proportion to the map as you zoom in. When the map is zoomed all the way out, the markers will be scaled to 20% (1/5 of their original size) and when the map is zoomed all the way in the markers will scale to 100% and display at their full original size.
Because the map on the left above is zoomed all the way out the star markers are very small and display at 20% of their original size. The map on the right above is zoomed all the way in so the markers display at 100% of their original size.

Now let’s suppose we want the markers to start out a little larger when the map is zoomed all the way out, and display at 100% when the map is zoomed in by 60%. We’ll set the Marker Zoom Limit to 3 as shown.

The map on the left below is zoomed all the way out and the markers are scaled to 33% (1/3 of their original size) instead of 20% so they appear larger to start. The map in the middle below is zoomed in by 60% and the markers are shown at their full size. The map on the right below is zoomed in all the way and demonstrates that the markers do not get any larger as you zoom in further because the Marker Zoom Limit is set to 3.

To adjust the Map Zoom Limit and Marker Zoom Limit options go to Map > Go To Map in the menu. The controls display below the map and above the hotspot thumbnails.

Markers are never scaled up larger than their original size, so a small symbol marker that is 16 x 16 pixels will never be displayed larger than 16 x16.
6 Importing Marker Shapes
You can import shape coordinates to define more complex shapes like country outlines, room or building footprints or shapes on a diagram.

6.1 How it works
The Import Marker Shapes feature lets you import one or more HTML Area tags and their shape coordinates and have MapsAlive automatically create a hotspot and a marker for each shape. This saves you from having to add hotspots one at a time.

HTML image maps
To understand how this works, you'll need some basic familiarity with HTML Image Maps and Area tags. An HTML Area tag is used for defining a clickable area within an image on a web page. It consists of a shape name and a set of coordinates that define the shape. There are a number of programs that let you define shapes to be used as Area tags. Some examples are Dreamweaver, Image Ready, Adobe Illustrator, and, MapEdit. For instructions on using MapEdit to generate the coordinates you need to create markers see Appendix A – MapEdit.

These programs let you trace over an image and they automatically generate the coordinates and the Area tags. An Area tag created by one of these programs might look like:

```
```

This Area tag defines the shape of the state of Colorado. The different parts of the Area tag that MapsAlive uses are described below.

Importing
You can import any HTML file (.htm or .html) containing Area tags. MapsAlive only uses the Area tags in your file and ignores all other HTML tags in the file.

When you import marker shapes you can select a marker style to use for the appearance of the markers you import. The color, opacity, and line thickness of the marker style you choose will be used for the markers MapsAlive creates from your imported coordinates.

Important: Each new marker created during an import gets the same appearance. Before importing Marker Shapes, choose a marker style from the Marker Style dropdown list on the import page. You can change a marker’s appearance later, but choosing an appropriate marker style now will save you time.

Marker Shape Tips and Techniques
Some marker styles work better than others, especially when using Ready Maps or other maps where the shapes are adjacent to each other (versus maps where the shapes don’t butt up against each other). Adjacent shapes work well with styles without a border. If the underlying map shapes have their own
color, a style without an invisible normal appearance is good. Some amount of experimenting is usually
needed to get the best combination of marker style for the specific map background.

6.2 Understanding Area tag attributes
MapsAlive uses the shape, coords, href, alt and title attributes of the Area tag when creating hotspot
markers. The shape and coords attributes are required. You must specify one or both of the alt and title
attributes. The href attribute is optional. All other Area tag attributes are ignored by MapsAlive.
Area tag attributes as used by MapsAlive

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Allowed Values</th>
<th>Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>shape</td>
<td>MapsAlive supports the standard shape attributes of circle, rect, or poly (polygon) in area tags as well as a line shape that lets you specify coordinates for a line.</td>
<td>Circle, rect, poly, line</td>
<td>Yes</td>
</tr>
<tr>
<td>coords</td>
<td>These are the coordinates for the shape. For rectangles, the coordinates specify the top-left and bottom-right corner of the rectangle. For circles, the coordinates specify the circle center and the radius. For polygons and lines, the coordinates specify the edges of the polygons.</td>
<td>Comma separated list of coordinates</td>
<td>Yes</td>
</tr>
<tr>
<td>alt</td>
<td>If specified, the value of the alt attribute is used as the Hotspot ID and as the Marker Name.</td>
<td>Plain text</td>
<td>Yes, if title not specified.</td>
</tr>
<tr>
<td>title</td>
<td>If specified, the value of the title attribute is used as the Hotspot Title. If the alt attribute is not specified, the title attribute is used as the Hotspot ID, the Marker Name, and the Hotspot title.</td>
<td>Plain text</td>
<td>Yes, if alt not specified.</td>
</tr>
<tr>
<td>href</td>
<td>The value of the href attribute is used to specify the URL for a hotspot that is clickable.</td>
<td>A URL</td>
<td>No</td>
</tr>
</tbody>
</table>

Table 1 - Import attributes

6.3 Import Marker Shape Options

Several import options give you even more control over how your shape markers are created:

Treat Polygon Shapes as Lines
MapsAlive supports the standard shape attributes of circle, square, or poly (polygon) in Area tags as well as a line shape that lets you specify coordinates for a line. You can include the shape=“line” attribute within your Area tags or you can check the Treat Polygon Shapes As Lines checkbox and MapsAlive will automatically treat any polygon shapes as lines by ignoring the last line segment in the coordinates.

Use Title Attribute As Tooltip
If you check Use Title Attribute As Tooltip, the tool tip associated with the marker will be set to the value of the title attribute, if any. This lets you automatically create tooltips for your markers.
Ignore Href attribute
Some programs that generate Area tags add the href attribute automatically, but if you do not want your hotspots to be clickable you can tell MapsAlive to ignore this attribute.

Set click action to link to href URL
If you include the href attribute as part of your Area tags, MapsAlive can automatically set the Click Action for the marker to “Link to URL” and the marker’s URL to the value of the href attribute. This lets you automatically define clickable markers and set their target URLs.

Set click action to link to href URL in new window
This option is the same as the previous one, but lets you select whether the URL replaces the page content or opens in a new window on click.

6.4 Updating marker shapes
You can use the Import Marker Shapes feature to quickly update the coordinates for markers that already exist. If an existing marker has the same name as the alt attribute of an imported Area tag, MapsAlive will replace the existing marker’s coordinates with the imported coordinates.

6.5 Combining multiple areas into one marker
You can create markers that are made up of discrete areas such as the islands of the state of Hawaii, or separate rooms on a floor plan. These are called hybrid markers. To combine more than one polygon shape into one marker, simply use the same value for the alt attribute for each of the areas.

6.6 Import Marker Shapes from HTML File
Once you have created your HTML file containing your area tags you are ready to import into MapsAlive and create your markers. Select the map in your tour that to which you want to import shapes. Then choose Tour > Import > Marker Shapes in the menu. Browse for the HTML file containing your area tags, choose a Marker Style that will be associated with each new marker created and click Import.

The marker styles that come with MapsAlive have names that describe the style.

The built-in MapsAlive marker style names follow this convention:

- Styles that start with **Border**: do not have fill colors, only borders.
- Styles that start with **Fill**: have normal and/or selected fill colors and may have a border or effects.
- Fill colors and border colors are shown as pairs where the first color is the normal color and the second color is the selected color.
- A color shown as **None** means there is no color specified so it will appear transparent.
- Effects appear at the end of the style name.
- Borders are 1 pixel unless a thickness is explicitly shown.
For example, a marker style called *Fill: Lavender/Purple Shadow* means that the style has a fill color of Lavender for the normal appearance and Purple for the selected appearance and has a drop shadow.

**Appendix A – MapEdit**

MapEdit is a simple utility program that lets you create HTML image maps by “tracing” over your image. This lets you create shapes for countries, states, counties, floor plans, buildings, diagrams – you name it. We’ve even used it to trace over a picture of a Boy Scout uniform to create shape markers for each component such as the shirt, badges, neckerchief, etc.!

You can create circle, rectangle and polygon shapes. MapEdit is $15 and is available here: [http://www.boutell.com/mapedit/](http://www.boutell.com/mapedit/). You download and install the program on your computer (Windows, Unix, and Mac versions available).

Once you have installed MapEdit on your computer you are ready to go. The instructions that follow are specifically for using MapEdit to create the HTML image maps that MapsAlive can import to create markers. They are not intended to be a complete user guide for MapEdit.

**Opening your image**

When you first run MapEdit it will ask you how you want to create your image map. If you have not yet traced any shapes, choose ‘Open An Image’. Then you can browse for your map image and click Open.

**Drawing shapes**

You can draw rectangles by clicking the blue square on the toolbar (see Figure 1). To draw circles, click the dark blue circle, and to draw polygons click the pink polygon symbol in the toolbar.

![MapEdit Toolbar](http://www.boutell.com/mapedit/)

**Figure 1 - MapEdit Toolbar**

Once you choose your drawing tool, you can click anywhere on your map image to begin drawing. For circles and rectangles you can just move the mouse to create the desired shape size. For polygons, move the mouse to the next point in your shape and click. Repeat until you have traced the entire polygon. When you click back at the starting point – either at or very close to the point – the polygon shape will close. For all shapes, a dialog will open that lets you specify attributes for the shape such as the Alt text or Title text. The only three fields from this dialog that MapsAlive uses are URL, Alt text and Title Text. These fields map to the MapsAlive Import attributes as follows:

<table>
<thead>
<tr>
<th>MapEdit Field</th>
<th>MapsAlive Import Attribute</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Figure 2 shows a polygon shape drawn around the state of Utah and the MapEdit dialog. MapsAlive will use the value specified for the URL as the URL for a hotspot that is clickable, the value specified in the Alternate (ALT) Text field as the Hotspot ID and the value specified in the Mouse-Over (TITLE) Text field as the Hotspot Title.

<table>
<thead>
<tr>
<th>URL</th>
<th>href</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alternate (ALT) Text</td>
<td>alt</td>
</tr>
<tr>
<td>Mouse-Over (TITLE) Text</td>
<td>title</td>
</tr>
</tbody>
</table>

Figure 2 - Drawing a polygon in MapEdit

Saving the HTML image map
Once you have traced all the shapes on your map, you can save the HTML by clicking File > Save HTML Document. The area tag for the example in Figure 2 looks like this:

```html
```

All of the area tags for the shapes you have drawn are saved in one HTML file. The resulting HTML file is what you will import into MapsAlive as described in the MapsAlive User Guide to Content Management.
**Updating shapes**

You can make changes to existing shapes or add additional shapes for a map image by running MapEdit and choosing 'Open a Web Page' when MapEdit first opens. This lets you browse for the HTML file you created above. You can select existing shapes with the Test and Edit Hotspots tool ( ) or add new shapes as described above.
Appendix B – Adobe Illustrator

This appendix briefly explains how to use Adobe Illustrator CS5, CS6, or CC to create marker shape coordinates that you can import into MapsAlive. For more information, see your Illustrator documentation. Some of the discussion applies to the three versions of Illustrator and some steps are different in CS5 and CS6 / CC.

Working with Shapes

In Illustrator, a shape is a closed path that forms a circle, rectangle or polygon. There are many ways to create shapes in Illustrator. You can use different tools such as the Pen, Magic Wand, Lasso, Pencil, Brush, Blob and so on since all of these tools create a path with points that define shapes. If you are drawing shapes on existing map artwork you may want to create a separate layer for the shapes, locking the base layer so you don’t accidentally make changes to the artwork. Also, if the shapes are on a separate layer you can manipulate them independently.

The shapes you define in Illustrator can be used in MapsAlive to create shape markers for hotspots that define the areas of your map that you want to be clickable and/or highlight when you mouse over them. Often your shapes will correspond to areas on underlying artwork. For example, shapes for a US map might correspond to colored states on the map. Or, shapes for an organizational chart might correspond to rectangles on a diagram.

To use your shapes with MapsAlive you must save them as HTML image maps that contain one or more area tags for each shape. The area tags contain coordinates that define the shapes. MapsAlive can import these image maps and automatically create shape markers. You will also save your artwork as a JPEG image to use as your map in a MapsAlive tour.

This document does not describe the different methods or tools in Illustrator to create shapes and assumes that you have already created shapes for your map or drawing. The following sections describe how to set shape attributes and export them from Illustrator.

Setting Shape Attributes

In order to obtain the shape coordinates in the format that MapsAlive can import, you must set attributes for each shape that you want to export. First, select a shape on your map – use the Selection Tool – and click anywhere within the shape. Be sure the shape’s path and all its points are part of the selection.
Next, open Illustrator's Attributes panel. To display the Attributes panel, check Attributes in the Window menu.

If the full Attribute panel is not visible in CS6, click the small menu icon in the upper right and then choose Show All.
Set the following attributes for each shape you want to export:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image Map</td>
<td>Polygon</td>
</tr>
<tr>
<td>URL</td>
<td>a descriptive label for the shape, e.g., Texas.</td>
</tr>
<tr>
<td></td>
<td>The value of the URL field is ultimately used as the hotspot Id when you import shapes into MapsAlive. Do not use an actual URL. Also, if you leave the URL field blank, Illustrator will not export an image map for the shape.</td>
</tr>
</tbody>
</table>

**Selecting multiple shapes**

If your artwork has multiple shapes that you want to treat as one marker shape in MapsAlive, you can select the different shapes together (multi-select) and set their attributes all at once. The URL field in the Attributes Panel will display `<multiple URLs>` when you select multiple shapes, but you can type your descriptive name in the field as usual. For example, you can select each island shape in the Hawaiian Islands together and then set the URL to Hawaii in one operation. Any shapes that have the same URL value will be treated as one shape when MapsAlive creates the marker.

To select multiple shapes, hold down the Shift key while clicking the different shapes. Another handy way to select multiple shapes is to use the Lasso tool.

**Note:** the instructions that follow are for exporting JPEG images from Illustrator. You can also export your image as a swf and use the shape markers you create with the swf file.

**Size Matters**

You will export your artwork as a JPEG image. This image is a raster graphic as opposed to a vector graphic and it will have a fixed width and height. The exported shape coordinates are relative to the size of the exported map image. Before you export your map image and shapes from Illustrator, you should size your artwork to at least the size of the map you want to use in MapsAlive. If the map image you export is larger than the map area in your tour, MapsAlive can scale the image and its corresponding shapes. For the best image and shape marker quality, you should export your map image at the exact size you need for your tour. Alternatively, if your map image is large and you want to be able to zoom in to see more detail you can use MapZoom and your shapes will still correspond to your map dimensions.
If you modify the size of the map image outside of Illustrator, e.g. cropping it in Photoshop, the shape coordinates no longer match the map image dimensions. In this case, if you upload the resized map image and import its shapes to a MapsAlive tour, the shapes will not align with the underlying map image.

**Important:** If you want to scale the map before you export it, make sure you select both the artwork and the shapes and resize both together or the shapes will not line up.

### Resizing Your Map Image

To change your map image and shapes, select all objects (Control-A on the PC, Command-A on the Mac). Then you can Shift-drag the bounding box surrounding your artwork to constrain the proportions while you resize. Or, you can type exact sizes in the Width and Height fields. Be sure to constrain the width and height proportions to maintain the aspect ratio.

![Width and Height fields in the toolbar area, with constrain proportions locked](image)

The important thing to remember is that the map image size and shape coordinates must stay in sync. If you need to change your map image dimensions, do so in Illustrator making sure to select both the map and the shapes, re-export your shapes and re-import both into MapsAlive.

Once you have set the Image Map attribute to Polygon and set the URL for all the shapes you want to export, you are ready to save the map image and shape coordinates.

### Exporting Your Map and Shapes in Illustrator CS5

Click **File > Save for Web & Devices** in the menu. This opens the Save dialog. Perform the following steps to export:

1. Select JPEG from the dropdown in the Preset section.
2. Click the **Image Size** tab and be sure the **New Size Percent** value is set to 100 (see below).
3. Uncheck **Clip to Artboard** to save just your artwork with no surrounding borders that might be part of the artboard (see below).
4. Click **Save**.
5. Choose a location and File name from the Save dialog.
6. Choose **HTML and Images (*.html)** from the **Save as type** dropdown.
7. Click **Save**.

Illustrator CS5 saves your shapes in an .html file and your map image as a JPEG file. The .html file is saved in the location you specified on the Save dialog. By default, the map image file is saved in a sub-folder called **images** in the same location specified on the Save dialog.
Exporting Your Map and Shapes in Illustrator CS6 or CC

Click File > Save for Web in the menu. This opens the Save dialog. Perform the following steps to export:

1. Select JPEG from the dropdown in the Preset section.
2. In the Image Size section, verify that the image size is correct and be sure the New Size Percent value is set to 100 (see below).
3. Uncheck Clip to Artboard to save just your artwork with no surrounding borders that might be part of the artboard (see below).
4. Click Preview in the bottom left or right of the Save dialog (depends on the version). This opens the image and shapes in a browser window.
   a. Scroll to the bottom of the browser window.
   b. Copy all of the code from the <html> tag to the </html> tag, inclusive.
   c. Open a text editor like Notepad and paste the code to a new file (do not use Word).
   d. Save the file with an extension of .htm or .html.
5. Back in the Illustrator Save dialog, click Save.
6. Choose a location and File name from the Save dialog.
7. Click Save.

You will need the .htm or .html file you saved in step 4 and the jpeg image file to import into MapsAlive.

New Size Percent

In order to maintain the correspondence between your map image size and shapes, always export your image size at 100%. If you export at anything other than 100%, the map image is saved at the new percentage, but the shapes are still saved at 100% so they will not align to the map. If you want to save your map image at a smaller or larger percentage, see Resizing Your Map Image in CS5 or Resizing Your Map Image in CS6.

Clip to Artboard

If you check the Clip to Artboard checkbox on the Image Size tab your saved image will be the size of the artboard rather than the size of the objects bounding box. This means anything outside the artboard will be automatically cropped or any white space between your artwork and the outside dimensions of the artboard will become part of your saved image. Either way, your shapes will still line up with your map, but the image may be cropped or have too much space around it. If you uncheck the Clip to Artboard checkbox, your image will be saved at the size of a rectangular bounding box that would surround your artwork.

Importing Your Map and Shapes into MapsAlive

Now you have your map image and shapes ready to use in a MapsAlive tour. You can upload your map image by choosing Map > Choose Map in the Tour Builder menu. To import your shapes, choose Tour > Import > Marker Shapes in the menu.